use strict;
my $str = 'CPE-MGT {
instance-type virtual-router;
interface ge-0/0/0.0;
routing-options {
static {
route 192.168.253.115/32 next-hop 192.168.100.1;
route 0.0.0.0/0 next-hop 192.168.100.1;
}
}
}
DATA {
instance-type virtual-router;
interface ge-0/0/1.0;
}
MGMT_BK {
instance-type virtual-router;
interface ge-0/0/2.0;
routing-options {
static {
route 192.168.253.115/32 next-hop 192.168.100.1;
route 0.0.0.0/0 next-hop 192.168.100.1;
}
}
}';
my $regex = qr~^(?P<name>[A-Z_-]+)\s+
(?P<body>\{
(?:(?:[^{}]+)|(?2))+
\})~mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}