const regex = new RegExp('^(?P<name>[A-Z_-]+)\\s+
(?P<body>\\{
(?:(?:[^{}]+)|(?2))+
\\})', 'gm')
const str = `CPE-MGT {
instance-type virtual-router;
interface ge-0/0/0.0;
routing-options {
static {
route 192.168.253.115/32 next-hop 192.168.100.1;
route 0.0.0.0/0 next-hop 192.168.100.1;
}
}
}
DATA {
instance-type virtual-router;
interface ge-0/0/1.0;
}
MGMT_BK {
instance-type virtual-router;
interface ge-0/0/2.0;
routing-options {
static {
route 192.168.253.115/32 next-hop 192.168.100.1;
route 0.0.0.0/0 next-hop 192.168.100.1;
}
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}