const regex = /https:\/\/drive\.google\.com\/open\?id=([^;]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/drive\\.google\\.com\\\/open\\?id=([^;]+)', '')
const str = `https://drive.google.com/open?id=1a897LLFCFiE7uKTnhQBEgslImSgos8Cf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}