re = /https:\/\/drive\.google\.com\/open\?id=([^;]+)/
str = 'https://drive.google.com/open?id=1a897LLFCFiE7uKTnhQBEgslImSgos8Cf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end