$re = '/https:\/\/drive\.google\.com\/open\?id=([^;]+)/';
$str = 'https://drive.google.com/open?id=1a897LLFCFiE7uKTnhQBEgslImSgos8Cf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);