const regex = /(^https:\/\/www.youtube.com\/embed\/)+([^.*])+(\?\S*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^https:\\\/\\\/www.youtube.com\\\/embed\\\/)+([^.*])+(\\?\\S*)', '')
const str = `https://www.youtube.com/embed/fM38xFb4_Fc?ecver=2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}