re = /(^https:\/\/www.youtube.com\/embed\/)+([^.*])+(\?\S*)/
str = 'https://www.youtube.com/embed/fM38xFb4_Fc?ecver=2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end