$re = '/(^https:\/\/www.youtube.com\/embed\/)+([^.*])+(\?\S*)/';
$str = 'https://www.youtube.com/embed/fM38xFb4_Fc?ecver=2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);