use strict;
my $str = 'std::string const&
std::string const
const std::string&
const char*
std::unordered_map<int, EnhancedGameObject*> const*
std::string * const
char const *';
my $regex = qr/(?:(.*)\s+(&|\*)\s*const|(.*)(?:\s+)const(?:\s*)(&|\*)?)$/mp;
my $subst = 'const \\1\\2\\3\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";