import re
regex = re.compile(r"(?:(.*)\s+(&|\*)\s*const|(.*)(?:\s+)const(?:\s*)(&|\*)?)$", flags=re.MULTILINE)
test_str = ("std::string const&\n"
"std::string const\n"
"const std::string&\n"
"const char*\n"
"std::unordered_map<int, EnhancedGameObject*> const*\n"
"std::string * const\n"
"char const *")
subst = "const \\1\\2\\3\\4"
result = regex.sub(subst, test_str)
if result:
print(result)