using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"casenumber(\s*[^\s\d]+\s*\d{7,8})+";
string input = @"Hi!
Hereby I would like to confirm that I will be present at the meeting about casenumber: 1234567 and 7654321.
Can you confirm that you have received this email?
Kind regards,
Random person";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}