re = /casenumber(\s*[^\s\d]+\s*\d{7,8})+/
str = 'Hi!
Hereby I would like to confirm that I will be present at the meeting about casenumber: 1234567 and 7654321.
Can you confirm that you have received this email?
Kind regards,
Random person'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end