import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "casenumber(\\s*[^\\s\\d]+\\s*\\d{7,8})+";
final String string = "Hi!\n\n"
+ "Hereby I would like to confirm that I will be present at the meeting about casenumber: 1234567 and 7654321.\n"
+ "Can you confirm that you have received this email?\n\n"
+ "Kind regards,\n"
+ "Random person";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}