#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<Street>(?:[A-Za-z\d]+\h)+)\h{2,}(?P<LAT>-?\d*\.\d+)\h{2,}(?P<LON>-?\d*\.\d+)$"
Local $sString = "A Kriel Street -25.69664263 28.41030434" & @CRLF & _
"Abraham Mogopodi Avenue -25.71338241 28.37033247" & @CRLF & _
"Absalome Street -25.70997386 28.3568847" & @CRLF & _
"Alan Paton Street -25.72122505 28.42021664" & @CRLF & _
"Alfred Nzo Crescent -25.6882444 28.41519928" & @CRLF & _
"Annah Mabusela Street -25.70656941 28.34339845" & @CRLF & _
"Anton Lembede Street -25.71813448 28.41874969" & @CRLF & _
"Aphane Nhlapo Street -25.7208474 28.38598257" & @CRLF & _
"Apple Close -25.71151327 28.38914898" & @CRLF & _
"Areyeng Street -25.72404151 28.38545561" & @CRLF & _
"Aseletho Street -25.71910848 28.41628606" & @CRLF & _
"Azikwelwa Street -25.70616386 28.40821879" & @CRLF & _
"Azondo Street -25.69615534 28.41117811" & @CRLF & _
"B Z Ndlazi Street -25.71074853 28.37073878" & @CRLF & _
"Badanile Avenue -25.71883255 28.42320088" & @CRLF & _
"Bahula Street -25.70728106 28.35488834" & @CRLF & _
"Baloyi Close -25.72553726 28.38641741" & @CRLF & _
"Bana Street -25.70942133 28.40631067" & @CRLF & _
"Banana Close -25.71194649 28.39090203"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")