const regex = /^(?P<Street>(?:[A-Za-z\d]+\h)+)\h{2,}(?P<LAT>-?\d*\.\d+)\h{2,}(?P<LON>-?\d*\.\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<Street>(?:[A-Za-z\\d]+\\h)+)\\h{2,}(?P<LAT>-?\\d*\\.\\d+)\\h{2,}(?P<LON>-?\\d*\\.\\d+)$', 'gm')
const str = `A Kriel Street -25.69664263 28.41030434
Abraham Mogopodi Avenue -25.71338241 28.37033247
Absalome Street -25.70997386 28.3568847
Alan Paton Street -25.72122505 28.42021664
Alfred Nzo Crescent -25.6882444 28.41519928
Annah Mabusela Street -25.70656941 28.34339845
Anton Lembede Street -25.71813448 28.41874969
Aphane Nhlapo Street -25.7208474 28.38598257
Apple Close -25.71151327 28.38914898
Areyeng Street -25.72404151 28.38545561
Aseletho Street -25.71910848 28.41628606
Azikwelwa Street -25.70616386 28.40821879
Azondo Street -25.69615534 28.41117811
B Z Ndlazi Street -25.71074853 28.37073878
Badanile Avenue -25.71883255 28.42320088
Bahula Street -25.70728106 28.35488834
Baloyi Close -25.72553726 28.38641741
Bana Street -25.70942133 28.40631067
Banana Close -25.71194649 28.39090203`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}