using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1?[-. ]*([0-9]{3}){1}[-. ]*([0-9]{3}){1}?[-. ]*([0-9]{4}){1}$";
string input = @"1 555 555 5555";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}