package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1?[-. ]*([0-9]{3}){1}[-. ]*([0-9]{3}){1}?[-. ]*([0-9]{4}){1}$`)
var str = `1 555 555 5555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}