re = /^1?[-. ]*([0-9]{3}){1}[-. ]*([0-9]{3}){1}?[-. ]*([0-9]{4}){1}$/m
str = '1 555 555 5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end