#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = " · ?(.*)"
Local $sString = "" & @CRLF & _
"ТРК CITY MALL" & @CRLF & _
"Zaporizhzhia, Zaporizhia Oblast · 050 463 9113" & @CRLF & _
"Shopping Center Ukraine" & @CRLF & _
"" & @CRLF & _
"# it's being captured as well" & @CRLF & _
"تطوان، المغرب · +212 669-599239" & @CRLF & _
"طنجة، المغرب · +212 5393-01148" & @CRLF & _
"طنجة، المغرب · +212 679-897627" & @CRLF & _
"" & @CRLF & _
"Coffeyville, KS · (620) 251-3330" & @CRLF & _
"Independence, KS · (620) 331-7177" & @CRLF & _
"Bartlesville, OK · (918) 333-6060" & @CRLF & _
"" & @CRLF & _
"Carrefour Guéret" & @CRLF & _
"Centre Commercial Auchan Domérat" & @CRLF & _
"Saint-Victor · 04 70 28 00 16" & @CRLF & _
"" & @CRLF & _
"ТРК Сіті Мол" & @CRLF & _
"Запоріжжя, Запорізька область · 050 463 9113" & @CRLF & _
"Дніпро, Дніпропетровська область · 050 463 9114" & @CRLF & _
"" & @CRLF & _
"Mühlhausen/Thüringen · 03601 815390" & @CRLF & _
"Nordhausen · 03631 600294" & @CRLF & _
"Laucha · 03622 900140" & @CRLF & _
"" & @CRLF & _
"CinecittàDue" & @CRLF & _
"Roma RM · 06 8746 5219" & @CRLF & _
"Roma RM · 06 8746 2321" & @CRLF & _
"" & @CRLF & _
"長野県上田市 · 0268-28-4551" & @CRLF & _
"長野県上田市 · 0268-42-1482" & @CRLF & _
"長野県松本市 · 0263-36-5258" & @CRLF & _
"" & @CRLF & _
"Langham Place" & @CRLF & _
"Mong Kok · 2393 4246" & @CRLF & _
"Mong Kok · 2396 2415" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Pärnu, Pärnu maakond · 522 6113" & @CRLF & _
"Rocca Al Mare Parking" & @CRLF & _
"Tallinn · 5561 7011" & @CRLF & _
"" & @CRLF & _
"Silkeborg · 86 81 41 11" & @CRLF & _
"Viborg · 22 40 77 75" & @CRLF & _
"Viborg · 86 69 68 95" & @CRLF & _
"" & @CRLF & _
"Pardubice · 724 372 891" & @CRLF & _
"Pardubice · 725 878 984" & @CRLF & _
"Osice · 725 752 422" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")