import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " · ?(.*)";
final String string = "\n"
+ "ТРК CITY MALL\n"
+ "Zaporizhzhia, Zaporizhia Oblast · 050 463 9113\n"
+ "Shopping Center Ukraine\n\n"
+ "# it's being captured as well\n"
+ "تطوان، المغرب · +212 669-599239\n"
+ "طنجة، المغرب · +212 5393-01148\n"
+ "طنجة، المغرب · +212 679-897627\n\n"
+ "Coffeyville, KS · (620) 251-3330\n"
+ "Independence, KS · (620) 331-7177\n"
+ "Bartlesville, OK · (918) 333-6060\n\n"
+ "Carrefour Guéret\n"
+ "Centre Commercial Auchan Domérat\n"
+ "Saint-Victor · 04 70 28 00 16\n\n"
+ "ТРК Сіті Мол\n"
+ "Запоріжжя, Запорізька область · 050 463 9113\n"
+ "Дніпро, Дніпропетровська область · 050 463 9114\n\n"
+ "Mühlhausen/Thüringen · 03601 815390\n"
+ "Nordhausen · 03631 600294\n"
+ "Laucha · 03622 900140\n\n"
+ "CinecittàDue\n"
+ "Roma RM · 06 8746 5219\n"
+ "Roma RM · 06 8746 2321\n\n"
+ "長野県上田市 · 0268-28-4551\n"
+ "長野県上田市 · 0268-42-1482\n"
+ "長野県松本市 · 0263-36-5258\n\n"
+ "Langham Place\n"
+ "Mong Kok · 2393 4246\n"
+ "Mong Kok · 2396 2415\n\n\n"
+ "Pärnu, Pärnu maakond · 522 6113\n"
+ "Rocca Al Mare Parking\n"
+ "Tallinn · 5561 7011\n\n"
+ "Silkeborg · 86 81 41 11\n"
+ "Viborg · 22 40 77 75\n"
+ "Viborg · 86 69 68 95\n\n"
+ "Pardubice · 724 372 891\n"
+ "Pardubice · 725 878 984\n"
+ "Osice · 725 752 422\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}