use strict;
my $str = '
ТРК CITY MALL
Zaporizhzhia, Zaporizhia Oblast · 050 463 9113
Shopping Center Ukraine
# it\'s being captured as well
تطوان، المغرب · +212 669-599239
طنجة، المغرب · +212 5393-01148
طنجة، المغرب · +212 679-897627
Coffeyville, KS · (620) 251-3330
Independence, KS · (620) 331-7177
Bartlesville, OK · (918) 333-6060
Carrefour Guéret
Centre Commercial Auchan Domérat
Saint-Victor · 04 70 28 00 16
ТРК Сіті Мол
Запоріжжя, Запорізька область · 050 463 9113
Дніпро, Дніпропетровська область · 050 463 9114
Mühlhausen/Thüringen · 03601 815390
Nordhausen · 03631 600294
Laucha · 03622 900140
CinecittàDue
Roma RM · 06 8746 5219
Roma RM · 06 8746 2321
長野県上田市 · 0268-28-4551
長野県上田市 · 0268-42-1482
長野県松本市 · 0263-36-5258
Langham Place
Mong Kok · 2393 4246
Mong Kok · 2396 2415
Pärnu, Pärnu maakond · 522 6113
Rocca Al Mare Parking
Tallinn · 5561 7011
Silkeborg · 86 81 41 11
Viborg · 22 40 77 75
Viborg · 86 69 68 95
Pardubice · 724 372 891
Pardubice · 725 878 984
Osice · 725 752 422
';
my $regex = qr/ · ?(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}