package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE)(?<L>[abcde])(?<M>[123]))(?&L)|(?&M)`)
var str = `Defini Abcd 165423`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}