re = /(?(DEFINE)(?<L>[abcde])(?<M>[123]))(?&L)|(?&M)/m
str = 'Defini Abcd 165423'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end