$re = '/(?(DEFINE)(?<L>[abcde])(?<M>[123]))(?&L)|(?&M)/m';
$str = 'Defini Abcd 165423';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);