# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^ *\|+ *| *\| *$|(\| *){2,}/\1/gm;t' <<< "3150779 | 3674-4 |Water Supply Plan
3637730 |
| 10903-155 | Layout 10903 DWG 155 29 M |
| 10903-155 | | Water Supply |"