#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^ *\|+ *| *\| *$|(\| *){2,}"
Local $sString = "3150779 | 3674-4 |Water Supply Plan" & @CRLF & _
"3637730 |" & @CRLF & _
" | 10903-155 | Layout 10903 DWG 155 29 M | " & @CRLF & _
"| 10903-155 | | Water Supply |"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)