import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ *\\|+ *| *\\| *$|(\\| *){2,}";
final String string = "3150779 | 3674-4 |Water Supply Plan\n"
+ "3637730 |\n"
+ " | 10903-155 | Layout 10903 DWG 155 29 M | \n"
+ "| 10903-155 | | Water Supply |";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}