using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{3})\w*";
string input = @"dehydrate foes fonts copy roster foolish tanks aching vinegar yawning wrong actress gigantic etched nifty huge camp swept dice fuming chlorine womanly aztec bounced swept";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}