// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w{3})\w*").unwrap();
let string = "dehydrate foes fonts copy roster foolish tanks aching vinegar yawning wrong actress gigantic etched nifty huge camp swept dice fuming chlorine womanly aztec bounced swept";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}