const regex = /(\w{3})\w*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{3})\\w*', 'g')
const str = `dehydrate foes fonts copy roster foolish tanks aching vinegar yawning wrong actress gigantic etched nifty huge camp swept dice fuming chlorine womanly aztec bounced swept`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}