using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^upload/(?<header>[a-z-]+/[a-z0-9-\.]+)/(?!\d+/)(?<class>[/a-z0-9_.]+)/(?<id_table>\d+)/(?<id_external>\d+/)?(?<entity>[a-z0-9-_]+)(/\w+)?\.(?<ext>\w+)$";
string input = @"upload/image/jpeg/.tables/.user/1/2/avatar/small.jpg";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}