import Foundation
let pattern = #"^upload/(?<header>[a-z-]+/[a-z0-9-\.]+)/(?!\d+/)(?<class>[/a-z0-9_.]+)/(?<id_table>\d+)/(?<id_external>\d+/)?(?<entity>[a-z0-9-_]+)(/\w+)?\.(?<ext>\w+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"upload/image/jpeg/.tables/.user/1/2/avatar/small.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}