$re = '~^upload/(?<header>[a-z-]+/[a-z0-9-\.]+)/(?!\d+/)(?<class>[/a-z0-9_.]+)/(?<id_table>\d+)/(?<id_external>\d+/)?(?<entity>[a-z0-9-_]+)(/\w+)?\.(?<ext>\w+)$~';
$str = 'upload/image/jpeg/.tables/.user/1/2/avatar/small.jpg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);