package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<first_sentence>.*[.?!])\s+(?<second_sentence>.*)\n`)
var str = `assumes word senses. Within
he arrive." After she had
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}