re = /(?<first_sentence>.*[.?!])\s+(?<second_sentence>.*)\n/m
str = 'assumes word senses. Within
he arrive." After she had
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end