$re = '/(?<first_sentence>.*[.?!])\s+(?<second_sentence>.*)\n/m';
$str = 'assumes word senses. Within
he arrive." After she had
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);