using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@([\w\-\.\']+(?:\s[\w\-\.\']+)?)$";
string input = @"@alia
@ranbir
@shilpa
@test_name
@test-name
@test.name
@test's_name
@alia bhat
@ranbir kapoor
@shilpa shetty
@ failed
@two spaces
@test ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}