re = /@([\w\-\.\']+(?:\s[\w\-\.\']+)?)$/m
str = '@alia
@ranbir
@shilpa
@test_name
@test-name
@test.name
@test\'s_name
@alia bhat
@ranbir kapoor
@shilpa shetty
@ failed
@two spaces
@test '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end