$re = '/@([\w\-\.\']+(?:\s[\w\-\.\']+)?)$/m';
$str = '@alia
@ranbir
@shilpa
@test_name
@test-name
@test.name
@test\'s_name
@alia bhat
@ranbir kapoor
@shilpa shetty
@ failed
@two spaces
@test ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);