import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+7|[7,8]\\ ?)(\\d{10}|(\\(?\\d{3}\\)?\\ ?\\d{3}[\\-,\\ ]?\\d{2}[\\-,\\ ]?\\d{2}))$";
final String string = "+79855310868\n"
+ "79855310868\n"
+ "7 985 531 08 68\n"
+ "+7(999)459-88-65\n"
+ "8 (999) 459-88-65\n"
+ "880084545454\n"
+ "88008454545411\n"
+ "465456465465\n"
+ "784545487878\n"
+ "12125465415646\n"
+ "454658498797894\n"
+ "231321546545\n"
+ "231321321316548\n"
+ "7889213554654\n"
+ "84456464641\n"
+ "89855310868";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}