$re = '/^(\+7|[7,8]\ ?)(\d{10}|(\(?\d{3}\)?\ ?\d{3}[\-,\ ]?\d{2}[\-,\ ]?\d{2}))$/m';
$str = '+79855310868
79855310868
7 985 531 08 68
+7(999)459-88-65
8 (999) 459-88-65
880084545454
88008454545411
465456465465
784545487878
12125465415646
454658498797894
231321546545
231321321316548
7889213554654
84456464641
89855310868';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);