use strict;
my $str = '+79855310868
79855310868
7 985 531 08 68
+7(999)459-88-65
8 (999) 459-88-65
880084545454
88008454545411
465456465465
784545487878
12125465415646
454658498797894
231321546545
231321321316548
7889213554654
84456464641
89855310868';
my $regex = qr/^(\+7|[7,8]\ ?)(\d{10}|(\(?\d{3}\)?\ ?\d{3}[\-,\ ]?\d{2}[\-,\ ]?\d{2}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}