#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(\w+)(?:\.(\1)(?:\.\1)+|\.(\1))\b"
Local $sString = "My.name.name.is.Inigo.Montoya.You.killed.my.father.father.father.Prepare.to.die.bar.bar.bar.bar.bar.foo.foo.baz.baz.baz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")