re = /\b(\w+)(?:\.(\1)(?:\.\1)+|\.(\1))\b/
str = 'My.name.name.is.Inigo.Montoya.You.killed.my.father.father.father.Prepare.to.die.bar.bar.bar.bar.bar.foo.foo.baz.baz.baz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end