import Foundation
let pattern = #"\b(\w+)(?:\.(\1)(?:\.\1)+|\.(\1))\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"My.name.name.is.Inigo.Montoya.You.killed.my.father.father.father.Prepare.to.die.bar.bar.bar.bar.bar.foo.foo.baz.baz.baz"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)