using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:keyboard|computer|black)(?: |$))+$";
string input = @"computer keyboard
computer keyboard black
computer keyboard black mouse
computerkeyboard
computer keyboardblack
computer keyboard black mouse";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}