const regex = /^(?:(?:keyboard|computer|black)(?: |$))+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:keyboard|computer|black)(?: |$))+$', 'gm')
const str = `computer keyboard
computer keyboard black
computer keyboard black mouse
computerkeyboard
computer keyboardblack
computer keyboard black mouse`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}