$re = '/^(?:(?:keyboard|computer|black)(?: |$))+$/m';
$str = 'computer keyboard
computer keyboard black
computer keyboard black mouse
computerkeyboard
computer keyboardblack
computer keyboard black mouse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);