using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1(*COMMIT)2";
string input = @"12 12 12 2 12 3 12 1 12 12 12 1 12 12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}