package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1(*COMMIT)2`)
var str = `12 12 12 2 12 3 12 1 12 12 12 1 12 12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}